Алгоритмизация и программирование

   
 

карта : главная

 

Пошаговая прокрутка алгоритма вопроса А12 демоверсии ЕГЭ 2012 на языке программирование Паскаль

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Ниже представлен фрагмент программы, записанный на разных языках программирования, в котором значения элементов сначала задаются, а затем меняются.

БЕЙСИК ПАСКАЛЬ СИ АЛГОРИТМИЧЕСКИЙ ЯЗЫК

FOR i=0  TO 9
A(i)=9-i
NEXT i
FOR i=0 TO 4
k = A(i)
A(i) = A(9-i)
A(9-i)=k
NEXT  i

for i:=0 to 9 do
A[i]:=9-i;
for i:=0 to 4 do begin
k:=A[i];
A[i]:=A[9-i];
A[9-i]:=k;
end;
for   (i=0;i<=9;i++)
A[i]=9-i;
for(i=0;i<=4;i++) {
k=A[i];
A[i]=A[9-i];
A[9-i]=k;}
нц для i от 0 до 9
A[i]:=9-i
кц
нц для i от 0 до 4
k:=A[i]
A[i]:=A[9-i]
A[9-i]:=k
кц

Чему будут равны элементы этого массива после выполнения фрагмента программы?

увеличить картинку на весь экран

Можно ли данную анимацию вставить на страничку своего сайта?

Да, можно! Для этого достаточно в нужное место вашей веб-страницы вставить следующий код:

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="810" height="610" title="Пошаговая прокрутка алгоритма вопроса А12 демоверсии ЕГЭ 2012"><param name="movie" value="http://it.somit.ru/flash/A12-2012.swf"><param name="quality" value="high"><embed src="http://it.somit.ru/flash/A12-2012.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="810" height="610"></embed>
</object>

Можно ли данную анимацию скачать?

ДА! Вот прямая ссыка на экзешник интерактивной анимации, демонстрирующей пошаговую прокрутку алгоритма вопроса А12 демоверсии ЕГЭ 2012 по информатике: СКАЧАТЬ

карта : главная : гостевая

 
© Александр Козлов, 2012
671717 г.Северобайкальск
 
Рейтинг@Mail.ru