Алгоритмизация и программирование

   
 

карта : главная

 

Интерактивная анимация, демонстрирующая один из способов обмениявания значениями элементов массива с помощью дополнительной переменной k.

В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Ниже представлен фрагмент программы, записанный на разных языках программирования, в котором значения элементов сначала задаются, а затем меняются.

БЕЙСИК ПАСКАЛЬ СИ АЛГОРИТМИЧЕСКИЙ ЯЗЫК

FOR i=0  TO 9
A(i)=9-i
NEXT i
FOR i=0 TO 4
k = A(i)
A(i) = A(9-i)
A(9-i)=k
NEXT  i

for i:=0 to 9 do
A[i]:=9-i;
for i:=0 to 4 do begin
k:=A[i];
A[i]:=A[9-i];
A[9-i]:=k;
end;
for   (i=0;i<=9;i++)
A[i]=9-i;
for(i=0;i<=4;i++) {
k=A[i];
A[i]=A[9-i];
A[9-i]=k;}
нц для i от 0 до 9
A[i]:=9-i
кц
нц для i от 0 до 4
k:=A[i]
A[i]:=A[9-i]
A[9-i]:=k
кц

Чему будут равны элементы этого массива после выполнения фрагмента программы? И еще один, на наш взгляд, важный момент на который нужно обратить внимание - это ответ на вопрос, что происходит с значением переменной цикла при выходе из цикла? Ответ на этот вопрос можно будет найти после пошаговой прокрутки данной интерактивной демонстрации.

увеличить картинку на весь экран


Можно ли данную анимацию вставить на страничку своего сайта?

Уважаемый коллега, если тебе понравился данный ролик, то знай, его можно вставить на страницу твоего сайта с твоим сценарием урока или с иным контентом, для этого достаточно вставить код, приведенный ниже, в нужное место своей страницы

Анимация остается работоспособной и при более коротком написании кода!

карта : главная : гостевая

 
© Александр Козлов, 2012
671717 г.Северобайкальск
 
Рейтинг@Mail.ru